Client authentication error when starting Visual Studio 2015.3

[Origin]: https://stackoverflow.com/questions/38516736/client-authentication-error-when-starting-visual-studio-2015-3

I just performed a clean install of VS2015.3 and I’m getting this in the Output window at startup:

We were unable to automatically populate your Visual Studio Team Services accounts.

The following error was encountered: TF400813: Resource not available for anonymous access. Client authentication required.

I’m not using VSTS at all, nor have I configured any connections to it. (I do, however, have a connection configured to an on-premises TFS instance.)

How may I dispense with this error message? I’d like to instruct Visual Studio to never attempt a connection to VSTS at startup.

shareimprove this question

In the top right corner of Visual Studio, you will find a colored box with your name or your initials inside. click the down arrow and then Account Settings. In the opening window, please click “Sign out” in the upper left part of the window.

After a restart of Visual Studio and signing back in, the error should be gone.

shareimprove this answer
Advertisements

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s